Colibri Page Builder <= 1.0.253 - Cross-Site Request Fogery via extend_builder

Cross-Site Request Forgery (CSRF)
CVE CVE-2024-1361
CVSS 4.3 (Medium)
Publicly Published February 22, 2024
Last Updated February 23, 2024
Researcher Lucio Sá


The Colibri Page Builder plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.253. This is due to missing or incorrect nonce validation on the apiCall() function. This makes it possible for unauthenticated attackers to call a limited set of functions that can be used to import images, delete posts, or save theme data via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Colibri Page Builder

Software Type Plugin
Software Slug colibri-page-builder (view on
Patched? Yes
Remediation Update to version 1.0.260, or a newer patched version
Affected Version
  • <= 1.0.253
Patched Version
  • 1.0.260

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.