Configurable Tag Cloud <= 5.2 - Cross-Site Request Forgery via ctc_options_page()

4.3
Cross-Site Request Forgery (CSRF)
CVE CVE-2023-28995
CVSS 4.3 (Medium)
Publicly Published March 30, 2023
Last Updated April 3, 2023
Researcher Abdi Pranata

Description

The Configurable Tag Cloud plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 5.2. This is due to missing nonce validation on the ctc_options_page() function. This makes it possible for unauthenticated attackers to modify the plugin's settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

References

Share

1 affected software package

Software Type Plugin
Software Slug configurable-tag-cloud-widget (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.3, or a newer patched version
Affected Version
  • <= 5.2
Patched Version
  • 5.3

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation