Configurable Tag Cloud <= 5.2 - Cross-Site Request Forgery via ctc_options_page()

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-28995
CVSS 4.3 (Medium)
Publicly Published March 30, 2023
Last Updated January 22, 2024
Researcher Abdi Pranata


The Configurable Tag Cloud plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 5.2. This is due to missing nonce validation on the ctc_options_page() function. This makes it possible for unauthenticated attackers to modify the plugin's settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Configurable Tag Cloud (CTC)

Software Type Plugin
Software Slug configurable-tag-cloud-widget (view on
Patched? Yes
Remediation Update to version 5.3, or a newer patched version
Affected Version
  • <= 5.2
Patched Version
  • 5.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.