Constant Contact Forms <= 1.8.7 Editor+ Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-24134
CVSS 5.5 (Medium)
Publicly Published September 6, 2020
Last Updated December 5, 2022
Researcher Nguyen Anh Tien


Unvalidated input and lack of output encoding in the Constant Contact Forms WordPress plugin, versions before 1.8.8, lead to multiple Stored Cross-Site Scripting vulnerabilities, which allowed high-privileged user (Editor+) to inject arbitrary JavaScript code or HTML in posts where the malicious form is embed.



Vulnerability Details for Constant Contact Forms

Software Type Plugin
Software Slug constant-contact-forms (view on
Patched? Yes
Remediation Update to version 1.8.8, or a newer patched version
Affected Version
  • < 1.8.8
Patched Version
  • 1.8.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.