Contact Form 7 <= 5.0.3 - Authorization Bypass

Improper Authorization
CVE CVE-2018-20979
CVSS 6.3 (Medium)
Publicly Published September 4, 2018
Last Updated January 22, 2024
Researcher Simon Scannell


The Contact Form 7 plugin for WordPress is vulnerable to authorization bypass due to capability_type mishandling in register_post_type in versions up to, and including, 5.0.3. This makes it possible for authenticated attackers with contributor level privileges and above to modify contact forms and potential supply paths to sensitive files that make sensitive information disclosure possible.



Vulnerability Details for Contact Form 7

Software Type Plugin
Software Slug contact-form-7 (view on
Patched? Yes
Remediation Update to version 5.0.4, or a newer patched version
Affected Version
  • < 5.0.4
Patched Version
  • 5.0.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.