Contact Form <= 3.82 - Authorization Bypass

Missing Authorization
CVSS 6.4 (Medium)
Publicly Published January 22, 2015
Last Updated January 22, 2024
Researcher Voxel@Night


The Contact Form plugin WordPress is vulnerable to authorization bypass in versions up to, and including, 3.82. This is due to missing capability checks and nonce validation on the add and remove language AJAX functions. This makes it possible for authenticated subscriber+ attackers to use the AJAX actions to manipulate the language of the vulnerable service and potentially inject malicious web scripts.



Vulnerability Details for Contact Form by BestWebSoft – Advanced Contact Us Form Builder for WordPress

Software Type Plugin
Software Slug contact-form-plugin (view on
Patched? Yes
Remediation Update to version 3.83, or a newer patched version
Affected Version
  • <= 3.82
Patched Version
  • 3.83

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.