Contact Form Email <= 1.3.11 - Cross-Site Request Forgery to Cross-Site Scripting

Cross-Site Request Forgery (CSRF)
CVSS 8.8 (High)
Publicly Published May 13, 2015
Last Updated January 22, 2024
Researcher Mahdi.Hidden (Ashiyane Digital Security Team) - Ashiyane Digital Security Team


The Contact Form Email plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.3.11. This is due to missing nonce validation on the 'cp_cfte_rep_enable' action. This makes it possible for unauthenticated attackers to modify plugin settings and inject malicious JavaScript via the 'cp_cfte_rep_message' parameter (in versions less than or equal to 1.1.4) via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Contact Form Email

Software Type Plugin
Software Slug contact-form-to-email (view on
Patched? Yes
Remediation Update to version 1.3.12, or a newer patched version
Affected Version
  • < 1.3.12
Patched Version
  • 1.3.12

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.