Contact Form Email <= 1.3.24 - Authenticated (Admin+) Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-42361
CVSS 4.8 (Medium)
Publicly Published November 11, 2021
Last Updated January 22, 2024
Researcher Mohammed Aadhil Ashfaq


The Contact Form Email WordPress plugin is vulnerable to Stored Cross-Site Scripting due to insufficient input validation and escaping via the name parameter found in the ~/trunk/ file which allowed attackers with administrative user access to inject arbitrary web scripts, in versions up to and including 1.3.24. This affects multi-site installations where unfiltered_html is disabled for administrators, and sites where unfiltered_html is disabled.



Vulnerability Details for Contact Form Email

Software Type Plugin
Software Slug contact-form-to-email (view on
Patched? Yes
Remediation Update to version 1.3.25, or a newer patched version
Affected Version
  • <= 1.3.24
Patched Version
  • 1.3.25

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.