Cimatti Contact Forms <= 1.4.11 - Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-24744
CVSS 5.5 (Medium)
Publicly Published September 27, 2021
Last Updated January 22, 2024
Researchers Felipe Restrepo Rodriguez (pfelilpe) - Pfelilpe
Sebastian Cruz Cardona


The Cimatti Contact Forms plugin for WordPress is vulnerable to Cross-Site Scripting in versions up to, and including, 1.4.11.This is due to insufficient input sanitization and output escaping on the title value of a form and makes it possible for attackers to inject arbitrary web scripts that execute in a victim's browser. This only affects multi-site installations and installations where unfiltered_html is disabled.



Vulnerability Details for WordPress Contact Forms by Cimatti

Software Type Plugin
Software Slug contact-forms (view on
Patched? Yes
Remediation Update to version 1.4.12, or a newer patched version
Affected Version
  • < 1.4.12
Patched Version
  • 1.4.12

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.