Continuous Image Carousel With Lightbox <= 1.0.15 - Reflected Cross-Site Scripting via search_term, order_by and order_pos

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-28792
CVSS 6.1 (Medium)
Publicly Published March 27, 2023
Last Updated January 22, 2024
Researcher thiennv


The Continuous Image Carousel With Lightbox for WordPress is vulnerable to Reflected Cross-Site Scripting via the search_term, order_by and order_pos parameters in versions up to, and including, 1.0.15 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Please note there is not enough information to distinguish this from CVE-2023-28776.



Vulnerability Details for Continuous Image Carousel With Lightbox

Software Type Plugin
Software Slug continuous-image-carousel-with-lightbox (view on
Patched? Yes
Remediation Update to version 1.0.16, or a newer patched version
Affected Version
  • <= 1.0.15
Patched Version
  • 1.0.16

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.