Copy or Move Comments < 1.0.1 - Cross-Site Scripting and SQL Injection

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVSS 8.8 (High)
Publicly Published June 16, 2015
Last Updated January 22, 2024
Researchers Kenneth Jepsen
Mikkel Vej
Morten Nortoft


The Copy or Move Comments plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via several parameters in versions up to, and including, 1.0.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. The plugin is also vulnerable to time-based blind SQL Injection via the ‘source_post’ and ‘target_post’ parameters due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.



1 affected software package

Software Type Plugin
Software Slug copy-or-move-comments (view on
Patched? Yes
Remediation Update to version 1.0.1, or a newer patched version
Affected Version
  • < 1.0.1
Patched Version
  • 1.0.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.