Cost of Goods for WooCommerce <= 2.8.6 - Cross-Site Request Forgery in save_costs

Cross-Site Request Forgery (CSRF)
CVSS 6.5 (Medium)
Publicly Published February 6, 2023
Last Updated February 13, 2023
Researcher Cat


The Cost of Goods for WooCommerce plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.8.6. This is due to missing or incorrect nonce validation on the save_costs function. This makes it possible for unauthenticated attackers to edit or save of prices via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug cost-of-goods-for-woocommerce (view on
Patched? Yes
Remediation Update to version 2.8.7, or a newer patched version
Affected Version
  • <= 2.8.6
Patched Version
  • 2.8.7

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.