Cost of Goods Sold (COGS): Cost & Profit Calculator for WooCommerce <= 3.2.8 - Reflected Cross-Site Scripting

6.1
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)
CVE CVE-2024-0821
CVSS 6.1 (Medium)
Publicly Published February 20, 2024
Last Updated February 20, 2024
Researcher Krzysztof Zając - CERT PL

Description

The Cost of Goods Sold (COGS): Cost & Profit Calculator for WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'section' parameter in all versions up to, and including, 3.2.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

References

Share

Vulnerability Details for Cost of Goods Sold (COGS): Cost & Profit Calculator for WooCommerce

Software Type Plugin
Software Slug cost-of-goods-for-woocommerce (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.2.9, or a newer patched version
Affected Version
  • <= 3.2.8
Patched Version
  • 3.2.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation