Crisp Live Chat <= 0.31 Cross-Site Request Forgery to Stored Cross-Site Scripting

Cross-Site Request Forgery (CSRF)
CVE CVE-2021-43353
CVSS 8.8 (High)
Publicly Published December 16, 2021
Last Updated December 21, 2022
Researcher José Aguilera


The Crisp Live Chat WordPress plugin is vulnerable to Cross-Site Request Forgery due to missing nonce validation via the crisp_plugin_settings_page function found in the ~/crisp.php file, which made it possible for attackers to inject arbitrary web scripts in versions up to, and including 0.31.



Vulnerability Details for Crisp – Live Chat and Chatbot

Software Type Plugin
Software Slug crisp (view on
Patched? Yes
Remediation Update to version 0.32, or a newer patched version
Affected Version
  • <= 0.31
Patched Version
  • 0.32

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.