Custom Post Type UI <= 1.13.4 - Cross-Site Request Forgery to Sensitive Information Exposure

5.4
Information Exposure
CVE CVE-2023-1623
CVSS 5.4 (Medium)
Publicly Published March 28, 2023
Last Updated April 5, 2023
Researcher Erwan LR - WPScan

Description

The Custom Post Type UI for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.13.4 . This is due to missing or incorrect nonce validation in the cptui_render_debuginfo_section function. This makes it possible for unauthenticated attackers to exfiltrate debug information gathered by the plugin via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. The information contains a list of installed and activated themes and plugins, version information for PHP, MySQL and Web Server.

References

Share

1 affected software package

Software Type Plugin
Software Slug custom-post-type-ui (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.13.5, or a newer patched version
Affected Version
  • <= 1.13.4
Patched Version
  • 1.13.5

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation