RegistrationMagic <= 5.2.2.6 - Cross-Site Request Forgery

4.3
Cross-Site Request Forgery (CSRF)
CVE CVE-2023-47645
CVSS 4.3 (Medium)
Publicly Published November 27, 2023
Last Updated December 4, 2023
Researcher thiennv

Description

The RegistrationMagic plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 5.2.2.6. This is due to missing or incorrect nonce validation on an unknown function. This makes it possible for unauthenticated attackers to perform an unauthorized action via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

References

Share

Vulnerability Details for RegistrationMagic – Custom User Registration Forms Plugin

Software Type Plugin
Software Slug custom-registration-form-builder-with-submission-manager (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.2.3.0, or a newer patched version
Affected Version
  • <= 5.2.2.6
Patched Version
  • 5.2.3.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation