RegistrationMagic <= 5.2.5.9 - Cross-Site Request Forgery

4.3
Cross-Site Request Forgery (CSRF)
CVE CVE-2024-25935
CVSS 4.3 (Medium)
Publicly Published February 20, 2024
Last Updated May 7, 2024
Researcher Majed Refaea

Description

The RegistrationMagic – Custom Registration Forms, User Registration, Payment, and User Login plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 5.2.5.9. This is due to missing or incorrect nonce validation on the rm_options_default_payment_method() function. This makes it possible for unauthenticated attackers to update the default payment method via a forged request granted they can trick an authenticated site user into performing an action such as clicking on a link.

References

Share

Vulnerability Details for RegistrationMagic – Custom User Registration Forms Plugin

Software Type Plugin
Software Slug custom-registration-form-builder-with-submission-manager (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.2.6.0, or a newer patched version
Affected Version
  • <= 5.2.5.9
Patched Version
  • 5.2.6.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation