Customer Reviews for WooCommerce <= 5.15.0 - Authenticated (Subscriber+) Local File Inclusion

8.1
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2023-0080
CVSS 8.1 (High)
Publicly Published January 23, 2023
Last Updated January 22, 2024
Researcher István Márton - Wordfence

Description

The Customer Reviews for WooCommerce plugin for WordPress is vulnerable to Directory Traversal in versions up to, and including, 5.15.0 via a shortcode attribute. This allows subscriber-level attackers to read the contents of arbitrary files on the server, which can contain sensitive information.

References

Share

Vulnerability Details for Customer Reviews for WooCommerce

Software Type Plugin
Software Slug customer-reviews-woocommerce (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.16.0, or a newer patched version
Affected Version
  • <= 5.15.0
Patched Version
  • 5.16.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation