Customer Reviews for WooCommerce <= 5.3.5 - Sensitive Data Exposure

4.3
Improper Authorization
CVE CVE-2022-40194
CVSS 4.3 (Medium)
Publicly Published September 22, 2022
Last Updated January 22, 2024
Researcher Muhammad Daffa - Patchstack Alliance

Description

The Customer Reviews for WooCommerce plugin contains several AJAX actions that are not protected by capability or nonce checks in versions up to, and including, 5.3.5. This allows authenticated users, such as subscribers, to perform actions that should be restricted to administrators, such as exporting sensitive data including unpublished reviews.

References

Share

1 affected software package

Software Type Plugin
Software Slug customer-reviews-woocommerce (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.3.6, or a newer patched version
Affected Version
  • <= 5.3.5
Patched Version
  • 5.3.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation