Customizer Export/Import <= 0.9.4 - Authenticated (Administrator+) PHP Object Injection

Deserialization of Untrusted Data
CVE CVE-2022-3380
CVSS 7.2 (High)
Publicly Published October 10, 2022
Last Updated December 6, 2022
Researcher Nguyen Duy Quoc Khanh


The Customizer Export/Import for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 0.9.4 via deserialization of untrusted input from an imported file. This allows administrator-level attackers to inject a PHP Object. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.



1 affected software package

Software Type Plugin
Software Slug customizer-export-import (view on
Patched? Yes
Remediation Update to version 0.9.5, or a newer patched version
Affected Version
  • <= 0.9.4
Patched Version
  • 0.9.5

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.