Customizer Export/Import <= 0.9.5 - Authenticated (Administrator+) PHP Object Injection

Deserialization of Untrusted Data
CVE CVE-2023-1347
CVSS 7.2 (High)
Publicly Published April 25, 2023
Last Updated January 22, 2024
Researcher Nguyen Duy Quoc Khanh


The Customizer Export/Import for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 0.9.5 via deserialization of untrusted input from an imported file. This allows administrator-level attackers to inject a PHP Object. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.



Vulnerability Details for Customizer Export/Import

Software Type Plugin
Software Slug customizer-export-import (view on
Patched? Yes
Remediation Update to version 0.9.6, or a newer patched version
Affected Version
  • <= 0.9.5
Patched Version
  • 0.9.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.