MultiVendorX <= 4.0.25 - Improper Authorization on REST Routes via 'save_settings_permission'

Improper Authorization
CVSS 8.6 (High)
Publicly Published September 12, 2023
Last Updated September 12, 2023


The MultiVendorX plugin for WordPress is vulnerable to unauthorized access of data, modification of data, and loss of data due to an improper capability check on the 'save_settings_permission' function for the REST routes instantiated by the 'mvx_rest_routes_react_module' function versions up to, and including, 4.0.25. This makes it possible for unauthenticated attackers to create, update, and delete vendors, retrieve sensitive information, and modify plugin settings.



1 affected software package

Software Type Plugin
Software Slug dc-woocommerce-multi-vendor (view on
Patched? Yes
Remediation Update to version 4.0.26, or a newer patched version
Affected Version
  • < 4.0.26
Patched Version
  • 4.0.26

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.