DecaLog <= 3.7.0 - Cross-Site Request Forgery via get_settings_page

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-27444
CVSS 4.3 (Medium)
Publicly Published March 5, 2023
Last Updated March 7, 2023
Researcher Mika


The DecaLog plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.7.0. This is due to missing or incorrect nonce validation on the get_settings_page function. This makes it possible for unauthenticated attackers to install the Device Detector (device-detector) or IP Locator (ip-locator) WordPress plugins via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug decalog (view on
Patched? Yes
Remediation Update to version 3.7.1, or a newer patched version
Affected Version
  • <= 3.7.0
Patched Version
  • 3.7.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.