Decorator - WooCommerce Email Customizer <= 1.2.7 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-48284
CVSS 4.3 (Medium)
Publicly Published November 2, 2023
Last Updated November 27, 2023
Researcher thiennv


The Decorator – WooCommerce Email Customizer plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.2.7. This is due to missing nonce validation on several functions such as ajax_reset(), wt_decorator_button_text(), wt_decorator_set_as_default(), and more. This makes it possible for unauthenticated attackers to modify several settings from the plugin via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug decorator-woocommerce-email-customizer (view on
Patched? Yes
Remediation Update to version 1.2.8, or a newer patched version
Affected Version
  • <= 1.2.7
Patched Version
  • 1.2.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.