demon image annotation <= 5.0 - Improper Input Restriction Validation

Improper Validation of Specified Quantity in Input
CVE CVE-2022-4171
CVSS 6.5 (Medium)
Publicly Published December 11, 2022
Last Updated December 13, 2022
Researcher Ori Gabriel - OP Research Team


The demon image annotation plugin for WordPress is vulnerable to improper input validation in versions up to, and including 5.0. This is due to the plugin improperly validating the number of characters supplied during an annotation despite there being a setting to limit the number characters input. This means that unauthenticated attackers can bypass the length restrictions and input more characters than allowed via the settings.



1 affected software package

Software Type Plugin
Software Slug demon-image-annotation (view on
Patched? Yes
Remediation Update to version 5.1, or a newer patched version
Affected Version
  • <= 5.0
Patched Version
  • 5.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.