Directorist <= 7.0.6.1 - Cross-Site Request Forgery to Arbitrary File Upload

8.8
Cross-Site Request Forgery (CSRF)
CVE CVE-2021-24981
CVSS 8.8 (High)
Publicly Published November 16, 2021
Last Updated January 22, 2024
Researcher lostbytes1

Description

The Directorist WordPress plugin before 7.0.6.2 was vulnerable to Cross-Site Request Forgery to Remote File Upload leading to arbitrary PHP shell uploads in the wp-content/plugins directory.

References

Share

Vulnerability Details for Directorist – WP Business Directory Plugin with Classified Ads Listings

Software Type Plugin
Software Slug directorist (view on wordpress.org)
Patched? Yes
Remediation Update to version 7.0.6.2, or a newer patched version
Affected Version
  • <= 7.0.6.1
Patched Version
  • 7.0.6.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation