Directorist <= 7.4.2.1 - Authenticated (Subscriber+) Insecure Direct Object Reference to Arbitrary User Password Change

8.8
Authorization Bypass Through User-Controlled Key
CVE CVE-2022-3930
CVSS 8.8 (High)
Publicly Published November 21, 2022
Last Updated January 22, 2024
Researcher cydave

Description

The Directorist plugin for WordPress is vulnerable to Insecure Direct Object References in versions up to, and including, 7.4.2.1. This is due to the plugin providing user-controlled access to objects, letting a user bypass authorization and access system resources. This makes it possible for subscriber-level attackers to change user passwords and potentially take over administrator accounts.

References

Share

Vulnerability Details for Directorist – WP Business Directory Plugin with Classified Ads Listings

Software Type Plugin
Software Slug directorist (view on wordpress.org)
Patched? Yes
Remediation Update to version 7.4.2.2, or a newer patched version
Affected Version
  • <= 7.4.2.1
Patched Version
  • 7.4.2.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation