Directorist <= 7.5.4 - Authenticated (Subscriber+) Arbitrary User Password Reset to Privilege Escalation

Improper Input Validation
CVE CVE-2023-1888
CVSS 8.8 (High)
Publicly Published June 1, 2023
Last Updated June 22, 2023
Researcher Alex Thomas - Wordfence


The Directorist plugin for WordPress is vulnerable to an arbitrary user password reset in versions up to, and including, 7.5.4. This is due to a lack of validation checks within login.php. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to reset the password of an arbitrary user and gain elevated (e.g., administrator) privileges.



1 affected software package

Software Type Plugin
Software Slug directorist (view on
Patched? Yes
Remediation Update to version 7.5.5, or a newer patched version
Affected Version
  • <= 7.5.4
Patched Version
  • 7.5.5

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.