Disqus Conditional Load <= 11.1.0 - Authenticated (Administrator+) Stored Cross-Site Scripting via plugin settings.

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-23732
CVSS 4.4 (Medium)
Publicly Published March 21, 2023
Last Updated June 23, 2023
Researcher yuyudhn


The Disqus Conditional Load plugin for WordPress is vulnerable to Stored Cross-Site Scripting via plugin options such as 'dcl_div_width', 'dcl_type', and others in versions up to, and including, 11.1.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers with administrator-level access, and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.



1 affected software package

Software Type Plugin
Software Slug disqus-conditional-load (view on wordpress.org)
Patched? Yes
Remediation Update to version 11.1.2, or a newer patched version
Affected Version
  • <= 11.1.1
Patched Version
  • 11.1.2

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.