Ditty <= 3.1.24 - Missing Authorization via save_ditty_permissions_check

Missing Authorization
CVE CVE-2023-47764
CVSS 5.3 (Medium)
Publicly Published November 13, 2023
Last Updated January 22, 2024
Researcher Abdi Pranata


The Ditty plugin for WordPress is vulnerable to unauthorized editing of dittys due to a missing capability check on the save_ditty_permissions_check function in versions up to, and including, 3.1.24. This makes it possible for unauthenticated attackers to edit dittys.



Vulnerability Details for Ditty – Responsive News Tickers, Sliders, and Lists

Software Type Plugin
Software Slug ditty-news-ticker (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.1.25, or a newer patched version
Affected Version
  • <= 3.1.24
Patched Version
  • 3.1.25

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.