Dokan <= 3.6.3 - Authenticated (Vendor+) Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-3194
CVSS 5.5 (Medium)
Publicly Published September 13, 2022
Last Updated January 22, 2024
Researcher Veshraj Ghimire


The Dokan plugin for WordPress is vulnerable to Stored Cross-Site Scripting via product reviews in versions up to, and including, 3.6.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with vendor permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was the result of the plugin enabling unfiltered_html capabilities for this user role.



Vulnerability Details for Dokan – Powerful WooCommerce Multivendor Marketplace Solution – Build Your Own Amazon, eBay, Etsy

Software Type Plugin
Software Slug dokan-lite (view on
Patched? Yes
Remediation Update to version 3.6.4, or a newer patched version
Affected Version
  • <= 3.6.3
Patched Version
  • 3.6.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.