Download Manager <= 3.2.42 - Reflected Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-1985
CVSS 6.1 (Medium)
Publicly Published June 2, 2022
Last Updated January 11, 2024
Researcher Rafie Muhammad - Patchstack


The Download Manager Plugin for WordPress is vulnerable to reflected Cross-Site Scripting in versions up to, and including 3.2.42. This is due to insufficient input sanitization and output escaping on the 'frameid' parameter found in the ~/src/Package/views/shortcode-iframe.php file.



Vulnerability Details for Download Manager

Software Type Plugin
Software Slug download-manager (view on
Patched? Yes
Remediation Update to version 3.2.43, or a newer patched version
Affected Version
  • <= 3.2.42
Patched Version
  • 3.2.43

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.