Google Tag Manager for WordPress <= 1.15 - Reflected Cross-Site Scripting via Site Search

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-1707
CVSS 6.1 (Medium)
Publicly Published May 19, 2022
Last Updated January 22, 2024
Researchers Cory Buecker


The Google Tag Manager for WordPress plugin for WordPress is vulnerable to reflected Cross-Site Scripting via the s parameter due to the site search populating into the data layer of sites with insufficient sanitization in versions up to an including 1.15. The affected file is ~/public/frontend.php and this could be exploited by unauthenticated attackers.



Vulnerability Details for GTM4WP – A Google Tag Manager (GTM) plugin for WordPress

Software Type Plugin
Software Slug duracelltomi-google-tag-manager (view on
Patched? Yes
Remediation Update to version 1.15.1, or a newer patched version
Affected Version
  • <= 1.15
Patched Version
  • 1.15.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.