E2Pdf <= 1.20.18 - Authenticated (Administrator+) PHP Object Injection

7.2
Deserialization of Untrusted Data
CVE CVE-2023-46154
CVSS 7.2 (High)
Publicly Published October 17, 2023
Last Updated January 22, 2024
Researcher Rein Daelman (trein)

Description

The E2Pdf plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.20.18 via deserialization of untrusted input within the import_action and ajax_upload functions. This makes it possible for authenticated attackers, with administrative-level access and above, to inject a PHP Object. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.

References

Share

1 affected software package

Software Type Plugin
Software Slug e2pdf (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.20.19, or a newer patched version
Affected Version
  • <= 1.20.18
Patched Version
  • 1.20.19

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation