EAN for WooCommerce <= 4.8.9 - Authenticated (Shop Manager+) Arbitrary Options Update

Improper Input Validation
CVE CVE-2024-34370
CVSS 5.3 (Medium)
Publicly Published May 3, 2024
Last Updated May 7, 2024
Researcher Majed Refaea


The EAN for WooCommerce plugin for WordPress is vulnerable to arbitrary options updates n all versions up to, and including, 4.8.9. This is due to insufficient restrictions on option values that can be supplied. This makes it possible for authenticated attackers, with Shop Manager-level access and above, to update arbitrary options that can be leveraged for privilege escalation.



Vulnerability Details for EAN, UPC, ISBN Generator: Product Barcode Inventory for WooCommerce

Software Type Plugin
Software Slug ean-for-woocommerce (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.9.0, or a newer patched version
Affected Version
  • <= 4.8.9
Patched Version
  • 4.9.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.