Easy Custom Auto Excerpt <= 2.4.12 - Sensitive Information Exposure

Missing Authorization
CVE CVE-2024-3312
CVSS 5.3 (Medium)
Publicly Published April 18, 2024
Last Updated May 2, 2024
Researcher Krzysztof Zając - CERT PL


The Easy Custom Auto Excerpt plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.4.12. This makes it possible for unauthenticated attackers to obtain excerpts of password-protected posts.



Vulnerability Details for Easy Custom Auto Excerpt

Software Type Plugin
Software Slug easy-custom-auto-excerpt (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.5.0, or a newer patched version
Affected Version
  • <= 2.4.12
Patched Version
  • 2.5.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.