Easy Digital Downloads <= 2.11.7 - Cross-Site Request Forgery to Arbitrary Post Deletion

Cross-Site Request Forgery (CSRF)
CVE CVE-2022-2387
CVSS 8.8 (High)
Publicly Published October 17, 2022
Last Updated January 25, 2023
Researcher Krzysztof Zając


The Easy Digital Downloads plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.11.7 . This is due to missing or incorrect nonce validation when deleting payment history. Additionally, the plugin does not ensure that the item about to be deleted is payment history. This makes it possible for unauthenticated attackers to delete arbitrary posts, via forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug easy-digital-downloads (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.0, or a newer patched version
Affected Version
  • <= 2.11.7
Patched Version
  • 3.0

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.