Easy Social Feed <= 6.5.2 - Missing Authorization to Settings Modification

Missing Authorization
CVE CVE-2023-6883
CVSS 4.3 (Medium)
Publicly Published January 2, 2024
Last Updated January 22, 2024
Researcher Lucio Sá


The Easy Social Feed plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on multiple AJAX functions in all versions up to, and including, 6.5.2. This makes it possible for authenticated attackers, with subscriber-level access and above, to perform unauthorized actions, such as modifying the plugin's Facebook and Instagram access tokens and updating group IDs.



Vulnerability Details for Easy Social Feed – Social Photos Gallery – Post Feed – Like Box

Software Type Plugin
Software Slug easy-facebook-likebox (view on wordpress.org)
Patched? Yes
Remediation Update to version 6.5.3, or a newer patched version
Affected Version
  • <= 6.5.2
Patched Version
  • 6.5.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.