Easy Media Replace <= 0.1.3 - Authenticated (Author+) Arbitrary File Deletion

Missing Authorization
CVE CVE-2022-46850
CVSS 8.1 (High)
Publicly Published March 28, 2023
Last Updated April 28, 2023
Researcher Jeong Seong Ho


The Easy Media Replace plugin for WordPress is vulnerable to arbitrary file deletion due to file path validation in the replace function in versions up to, and including, 0.1.3. This makes it possible for author-level attackers to delete arbitrary files on the affected site's server. File deletion is limited to files of the same mime type the attacker can upload.



1 affected software package

Software Type Plugin
Software Slug easy-media-replace (view on wordpress.org)
Patched? Yes
Remediation Update to version 0.2.0, or a newer patched version
Affected Version
  • <= 0.1.3
Patched Version
  • 0.2.0

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.