Easy Property Listings <= 3.5.3 - Missing Authorization via epl_update_listing_coordinates()

Missing Authorization
CVE CVE-2024-32799
CVSS 5.3 (Medium)
Publicly Published April 22, 2024
Last Updated April 29, 2024
Researcher Mika


The Easy Property Listings plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the epl_update_listing_coordinates function in versions up to, and including, 3.5.3. This makes it possible for unauthenticated attackers to update listing co-ordinates.



Vulnerability Details for Easy Property Listings

Software Type Plugin
Software Slug easy-property-listings (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.5.4, or a newer patched version
Affected Version
  • <= 3.5.3
Patched Version
  • 3.5.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.