Easy Social Icons <= 3.2.4 - Missing Authorization via cnss_save_ajax_order

Missing Authorization
CVE CVE-2023-33998
CVSS 4.3 (Medium)
Publicly Published November 7, 2023
Last Updated November 21, 2023
Researcher Nguyen Anh Tien


The Easy Social Icons plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the cnss_save_ajax_order function in versions up to, and including, 3.2.4. This makes it possible for authenticated attackers, with subscriber-level access and above, to change the order of social icons.



1 affected software package

Software Type Plugin
Software Slug easy-social-icons (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.2.5, or a newer patched version
Affected Version
  • <= 3.2.4
Patched Version
  • 3.2.5

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.