Easy WP SMTP <= 1.3.9 - Missing Authorization to Arbitrary Options Update

9.8
Missing Authorization
CVE CVE-2019-25141
CVSS 9.8 (Critical)
Publicly Published March 17, 2019
Last Updated June 7, 2023
Researcher Jerome Bruandet - NinTechNet

Description

The Easy WP SMTP plugin for WordPress is vulnerable to authorization bypass in versions up to, and including, 1.3.9. This is due to missing capability checks on the admin_init() function, in addition to insufficient input validation. This makes it possible for unauthenticated attackers to modify the plugins settings and arbitrary options on the site that can be used to inject new administrative user accounts.

Wordfence blocked 154 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for Easy WP SMTP by SendLayer – WordPress SMTP and Email Log Plugin

Software Type Plugin
Software Slug easy-wp-smtp (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.3.9.1, or a newer patched version
Affected Version
  • < 1.3.9.1
Patched Version
  • 1.3.9.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation