Easy WP SMTP by SendLayer <= 2.3.0 - Exposure of Sensitive Information via the UI

2.7
Storing Passwords in a Recoverable Format
CVE CVE-2024-3073
CVSS 2.7 (Low)
Publicly Published June 12, 2024
Last Updated July 10, 2024
Researcher Finsand

Description

The Easy WP SMTP by SendLayer – WordPress SMTP and Email Log Plugin plugin for WordPress is vulnerable to information exposure in all versions up to, and including, 2.3.0. This is due to plugin providing the SMTP password in the SMTP Password field when viewing the settings. This makes it possible for authenticated attackers, with administrative-level access and above, to view the SMTP password for the supplied server. Although this would not be useful for attackers in most cases, if an administrator account becomes compromised this could be useful information to an attacker in a limited environment.

References

Share

Vulnerability Details for Easy WP SMTP by SendLayer – WordPress SMTP and Email Log Plugin

Software Type Plugin
Software Slug easy-wp-smtp (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.3.1, or a newer patched version
Affected Version
  • <= 2.3.0
Patched Version
  • 2.3.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation