eaSYNC <= 1.3.11 - Reflected Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-38384
CVSS 6.1 (Medium)
Publicly Published July 20, 2023
Last Updated April 1, 2024
Researcher OZ1NG (TOOR, LISA)


The eaSYNC plugin for WordPress is vulnerable to Reflected Cross-Site Scripting in versions up to, and including, 1.3.11 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.



Vulnerability Details for Free Booking Plugin for Hotels, Restaurants and Car Rentals – eaSYNC Booking

Software Type Plugin
Software Slug easync-booking (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.3.12, or a newer patched version
Affected Version
  • <= 1.3.11
Patched Version
  • 1.3.12

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.