EazyDocs <= 2.3.5 - Missing Authorization via doc_one_page and edit_doc_one_page

Missing Authorization
CVE CVE-2023-47648
CVSS 6.5 (Medium)
Publicly Published November 7, 2023
Last Updated February 6, 2024
Researcher Skalucy


The EazyDocs plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the doc_one_page and edit_doc_one_page functions in versions up to, and including, 2.3.5. This makes it possible for unauthenticated attackers to publish and edit the plugin's OnePage document. CVE-2023-6029 may be a duplicate of this issue.



Vulnerability Details for EazyDocs – Most Powerful Knowledge base, wiki, Documentation Builder Plugin

Software Type Plugin
Software Slug eazydocs (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.3.6, or a newer patched version
Affected Version
  • <= 2.3.5
Patched Version
  • 2.3.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.