eCommerce Product Catalog for WordPress <= 3.3.25 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-5979
CVSS 5.4 (Medium)
Publicly Published November 13, 2023
Last Updated December 22, 2023
Researcher Krzysztof Zając - CERT PL


The eCommerce Product Catalog Plugin for WordPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to 3.3.26 (exclusive). This is due to missing or incorrect nonce validation when handling product and category settings. This makes it possible for unauthenticated attackers to bulk delete, reset, or reassign products and categories via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug ecommerce-product-catalog (view on
Patched? Yes
Remediation Update to version 3.3.26, or a newer patched version
Affected Version
  • < 3.3.26
Patched Version
  • 3.3.26

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.