Ecwid Ecommerce Shopping Cart <= 4.4.3 - Unauthenticated PHP Object injection

9.8
Deserialization of Untrusted Data
CVSS 9.8 (Critical)
Publicly Published August 8, 2016
Last Updated January 25, 2023
Researcher Yorick Koster, - sumofpwn

Description

The Ecwid Ecommerce Shopping Cart plugin for WordPress is vulnerable to PHP Object Injection in versions before 4.4.4 via deserialization of untrusted input from the vulnerable cookie parameter 'ecwid_oauth_state' in the _load_state function. This allows unauthenticated attackers to inject a PHP Object. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.

References

Share

Vulnerability Details for Ecwid Ecommerce Shopping Cart

Software Type Plugin
Software Slug ecwid-shopping-cart (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.4.4, or a newer patched version
Affected Version
  • <= 4.4.3
Patched Version
  • 4.4.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation