Ecwid Ecommerce Shopping Cart <= 6.12.3 - Missing Authorization on multiple functions

5.4
Missing Authorization
CVSS 5.4 (Medium)
Publicly Published November 7, 2023
Last Updated January 22, 2024

Description

The Ecwid Ecommerce Shopping Cart plugin for WordPress is vulnerable to unauthorized access of data and modification of data due to missing capability checks on multiple functions in all versions up to, and including, 6.12.3. This makes it possible for authenticated attackers to access developer tool pages.

References

Share

Vulnerability Details for Ecwid Ecommerce Shopping Cart

Software Type Plugin
Software Slug ecwid-shopping-cart (view on wordpress.org)
Patched? Yes
Remediation Update to version 6.12.4, or a newer patched version
Affected Version
  • <= 6.12.3
Patched Version
  • 6.12.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation