ElasticPress <= 5.1.0 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2024-35684
CVSS 4.3 (Medium)
Publicly Published June 6, 2024
Last Updated June 12, 2024
Researcher Ananda Dhakal


The ElasticPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 5.1.0. This is due to missing or incorrect nonce validation on the do_sync function. This makes it possible for unauthenticated attackers to sync data via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for ElasticPress

Software Type Plugin
Software Slug elasticpress (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.1.1, or a newer patched version
Affected Version
  • <= 5.1.0
Patched Version
  • 5.1.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.