Elementor Pro <= 2.0.9 - Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2018-18379
CVSS 6.1 (Medium)
Publicly Published October 26, 2018
Last Updated January 22, 2024
Researcher Christopher Vella


The elementor-edit-template class in wp-admin/customize.php in the Elementor Pro plugin before 2.0.10 for WordPress has XSS.



1 affected software package

Software Type Plugin
Software Slug elementor-pro
Patched? Yes
Remediation Update to version 2.0.10, or a newer patched version
Affected Version
  • < 2.0.10
Patched Version
  • 2.0.10

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.