Elementor <= 3.13.1 - Missing Authorization to Settings Update

Missing Authorization
CVSS 5.4 (Medium)
Publicly Published May 12, 2023
Last Updated May 12, 2023


The Elementor plugin for WordPress is vulnerable to unauthorized modification of data due to missing capability checks on the register_as_beta_tester(), ajax_enable_safe_mode(), ajax_get_category_items(), and ajax_re_migrate_globals() functions called via AJAX actions in versions up to, and including, 3.13.1. This makes it possible for authenticated attackers with minimal permissions such as subscribers to perform many actions such as registering the site for beta testing, enabling safe mode, remigrating globals and retrieving category items.



Vulnerability Details for Elementor Website Builder – More than Just a Page Builder

Software Type Plugin
Software Slug elementor (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.13.2, or a newer patched version
Affected Version
  • <= 3.13.1
Patched Version
  • 3.13.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.